2010年12月22日水曜日

GentooにJDK1.5を仕込む

イケテルLinuxディストリビューションであるGentooでは、サポートの切れたJDK1.5なんて、パッケージから既に除外されています。

実際のところ、セキュリティホールが見つかっても放置されるJDK1.5なんて使わないほうがいいし、インストールだってしない方がいいに決まっています。

ですが、Android君がJDK1.5を所望しているので、仕方なくGentooにJDK1.5をインストールしました。
JDK1.5はPortageツリーからは無くなっていますが、java-overlayに残っているので、laymanでjava-overlayを追加してインストールすればOK。

$ sudo emerge install layman
$ echo "source /var/lib/layman/make.conf" | sudo tee -a /etc/make.conf
$ sudo layman -S
$ sudo layman -a java-overlay
$ sudo emerge -av =dev-java/sun-jdk-1.5.0.22-r2
こんな感じ。

0 コメント: